

<!DOCTYPE HTML>
<html lang="en-US">
<head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#">
<meta charset="UTF-8">
<title>Unique 2-in-1 calculator app adds up to surprise hit for retired engineer in Japan - The Mainichi</title>
<meta name="viewport" content="width=1100,user-scalable=yes">
<meta name="format-detection" content="telephone=no">
<meta name="title" content="Unique 2-in-1 calculator app adds up to surprise hit for retired engineer in Japan">
<meta name="keywords" content="Science,Technology,Latest Articles,The Mainichi,JAPAN">
<meta name="description" content="TOKYO -- A 63-year-old man in Japan who is an avid iPhone user has dedicated some of his post-retirement years to developing a popular, unique app tha">
<meta name="firstcreate" content="2022-09-18 09:00:00">
<meta name="lastupdate" content="2022-09-18 09:00:11">
<meta name="mainichi:art-type" content="all">
<meta name="mixi-check-robots" content="noimage">
<meta name="robots" content="noarchive"><meta name="Hatena::Bookmark" content="noindex"><link rel="canonical" href="https://mainichi.jp/english/articles/20220916/p2a/00m/0sc/017000c">
<link rel="alternate" href="https://mainichi.jp/articles/20220910/k00/00m/040/136000c" hreflang="ja" >
<link rel="alternate" href="https://mainichi.jp/english/articles/20220916/p2a/00m/0sc/017000c" hreflang="en">


<!--| favicon |-->
<link rel="icon" href="https://cdn.mainichi.jp/vol1/images/icon/english/favicon.ico">
<link rel="apple-touch-icon-precomposed" href="https://cdn.mainichi.jp/vol1/images/icon/english/apple-touch.png">

<!--| open graph |-->
<meta property="og:title" content="Unique 2-in-1 calculator app adds up to surprise hit for retired engineer in Japan - The Mainichi">
<meta property="og:type" content="article">
<meta property="og:locale" content="en_US">
<meta property="og:locale:alternate" content="ja_JP"><meta property="og:site_name" content="The Mainichi">
<meta property="og:url" content="https://mainichi.jp/english/articles/20220916/p2a/00m/0sc/017000c">
<meta property="og:description" content="TOKYO -- A 63-year-old man in Japan who is an avid iPhone user has dedicated some of his post-retirement years to developing a popular, unique app tha">
<meta property="og:image" content="https://cdn.mainichi.jp/vol1/2022/09/16/20220916p2a00m0sc014000p/0c10.jpg?1">

<!--| twitter card |-->
<meta name="twitter:site" content="@themainichi">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:image:src" content="https://cdn.mainichi.jp/vol1/2022/09/16/20220916p2a00m0sc014000p/0c10.jpg?1">
<meta name="twitter:title" content="Unique 2-in-1 calculator app adds up to surprise hit for retired engineer in Japan">
<meta name="twitter:description" content="TOKYO -- A 63-year-old man in Japan who is an avid iPhone user has dedicated some of his post-retirement years to developing a popular, unique app tha">
<meta name="twitter:url" content="https://mainichi.jp/english/articles/20220916/p2a/00m/0sc/017000c">

<!--| Facebook |-->
<meta property="fb:app_id" content="829413960504653">
<meta property="article:publisher" content="https://www.facebook.com/themainichi/">
<meta property="article:author" content="https://www.facebook.com/themainichi/">
<!-- すべて：ページタイトル -->
<meta name="cXenseParse:recs:mai-title" content="Unique 2-in-1 calculator app adds up to surprise hit for retired engineer in Japan">

<!-- 記事のみ：初出時刻 -->
<meta name="cXenseParse:recs:publishtime" content="2022-09-18T09:00:00.000+0900">

<!-- 記事のみ：記事ID -->
<meta name="cXenseParse:articleid" content="20220916p2a00m0sc017000c1">

<!-- 記事のみ：サブジェクトコード -->
<meta name="cXenseParse:mai-category" content="m300000026" data-separator=",">

<!-- 記事のみ：記事ID -->
<meta name="cXenseParse:mai-atclid" content="20220916p2a00m0sc017000c">

<!-- すべて：有料記事判別 -->
<meta name="cXenseParse:mai-fee-charging" content="">

<!-- 記事のみ：関連見出し -->
<meta name="cXenseParse:mai-keywordline" content="">

<!-- すべて：写真URL -->
<meta name="cXenseParse:recs:image" content="https://cdn.mainichi.jp/vol1/2022/09/16/20220916p2a00m0sc014000p/0c6.jpg?1">

<!-- すべて：ページ種別 -->
<meta name="cXenseParse:pageclass" content="article">

<!-- チャンネル：ページ判別 -->
<meta name="cXenseParse:mai-channel" content="false">

<!-- チャンネル：チャンネル名 -->
<meta name="cXenseParse:mai-channeltitle" content="">

<!-- チャンネル：チャンネルURL -->
<meta name="cXenseParse:mai-channelurl" content="">

<!-- 記事のみ：大ジャンル -->
<meta name="cXenseParse:mai-genrecd-big" content="p2a">

<!-- 記事のみ：中ジャンル -->
<meta name="cXenseParse:mai-genrecd-medium" content="00m">

<!-- 記事のみ：小ジャンル -->
<meta name="cXenseParse:mai-genrecd-small" content="0sc">

<!-- すべて：著者 -->
<meta name="cXenseParse:author" content="" data-separator=",">

<!-- 複数処理：プレミア配下カテゴリ、連載、テーマ、カントリー、ロケーション、汎用、特設 -->
<meta name="cXenseParse:mai-ch-keyword" content="" data-separator=",">
<meta name="cXenseParse:mai-ch-series" content="" data-separator=",">
<meta name="cXenseParse:mai-ch-theme" content="" data-separator=",">
<meta name="cXenseParse:mai-ch-country" content="JAPAN" data-separator=",">
<meta name="cXenseParse:mai-ch-location" content="" data-separator=",">
<meta name="cXenseParse:mai-ch-special" content="" data-separator=",">
<meta name="cXenseParse:mai-ch-general" content="" data-separator=",">
<!-- 記事のみ：トップ8に編成されている記事 -->
<meta name="cXenseParse:mai-top-selection" content="false">

<!-- 記事のみ：本文の文字数 -->
<meta name="cXenseParse:mai-characters" content="U-3900">

<!-- 記事のみ：記事更新時間 -->
<meta property="article:modified_time" content="2022-09-18T09:00:11000+0900">

<!-- すべて：エンタイトルメント -->
<meta name="cXenseParse:mai-entitlement" content="free-entry">

<!-- 記事のみ：ラベル -->
<meta name="cXenseParse:mai-articlelabel" content="" data-separator=",">

<!-- チャンネル：テンプレート種類（対象：テーマ、タイムライン、特設、汎用） -->
<meta name="cXenseParse:mai-ch-template" content="">


<!-- すべて：カテゴリ -->
<meta name="cXenseParse:mai-ch-category" content="Science,Technology,Latest Articles" data-separator=",">

<!-- すべて：カテゴリ1 -->
<meta name="cXenseParse:mai-ch-category1" content="Science,Latest Articles" data-separator=",">

<!-- すべて：カテゴリ2 -->
<meta name="cXenseParse:mai-ch-category2" content="" data-separator=",">

<!-- 記事のみ：写真の有無 -->
<meta name="cXenseParse:mai-tf-image" content="true">

<!-- 記事のみ：動画の有無 -->
<meta name="cXenseParse:mai-tf-video" content="false">

<!-- 記事のみ：公開年、年月、年月日 -->
<meta name="cXenseParse:mai-pubyear" content="2022">
<meta name="cXenseParse:mai-pubmonth" content="202209">
<meta name="cXenseParse:mai-pubday" content="20220918">

<!-- 記事のみ：タイアップ記事 -->
<meta name="cXenseParse:mai-tieup" content="false">





<!-- Cxense 計測タグ #5872 -->
<script type="text/javascript">
function cx_hasLocalStorage() {
  try { return typeof window.localStorage === 'object' && typeof window.localStorage.getItem === 'function'; } catch (e) { return false; }
}
function cx_getOptOutStatus(key) {
  var status = false;
  if (cx_hasLocalStorage()) {
    var optedOut = window.localStorage.getItem(key);
    if (optedOut && optedOut === 'true') {
      status = true;
    }
  }
  return status;
}
var cX = window.cX || {}; cX.callQueue = cX.callQueue || [];
cX.options = cX.options || {};
cX.options.consent = cx_getOptOutStatus('cx_optOut');
cX.CCE = cX.CCE || {}; cX.CCE.callQueue = cX.CCE.callQueue || [];
cX.callQueue.push(["invoke", function() {
  var cx_prnd = cX.getCookie('prnd');
  if(cx_prnd){
    cX.setRandomId(cx_prnd);
  }
  if(cX.library.m_isNewUser) {cX.setCustomParameters({"newuser":"true"}); cX.startSessionAnnotation({"newuser_S":"true"});}
}]);
cX.callQueue.push(['setSiteId', '9222356687186286883']);
</script>
<script type='text/javascript'>
document.write('<scr'+'ipt type="text/javascript" src="http'+(location.protocol==='https:'?'s://s':'://')+'cdn.cxense.com/cx.js"></scr'+'ipt>');
</script>

<!-- GA用計測タグ-->
<script>
dataLayer = [{
'art-type':'all',
'mai-category':'m300000026',
'mai-fee-charging':'',
'mai-keywordline':'',
'mai-channel':'false',
'mai-channeltitle':'',
'mai-genrecd-big':'p2a',
'mai-genrecd-medium':'00m',
'mai-genrecd-small':'0sc',
'mai-ch-keyword':'',
'mai-ch-series':'',
'author':'',
'mai-ch-theme':'',
'mai-ch-country':'JAPAN',
'mai-ch-location':'',
'mai-ch-special':'',
'mai-ch-general':'',
'mai-ch-category':['Science','Technology','Latest Articles'],
'mai-top-selection':'false',
'mai-characters':'U-3900',
'mai-entitlement':'free-entry',
'mai-articlelabel':'',
'mai-ch-template':'',
'mai-ch-category1':['Science','Latest Articles'],
'mai-ch-category2':'',
'mai-tf-image':'true',
'mai-tf-video':'false',
'mai-pubyear':'2022',
'mai-pubmonth':'202209',
'mai-pubday':'20220918',
'mai-servicegroup':'',
'mai-subscriber':''}];</script>

<meta name="ob:title" content="Unique 2-in-1 calculator app adds up to surprise hit for retired engineer in Japan">
<meta name="ob:keywordline" content="">



<!--| CSS |-->
<link rel="stylesheet" href="//cdn.mainichi.jp/vol1/css/pc/common_v3.css?202103">
<link rel="stylesheet" href="//cdn.mainichi.jp/vol1/css/pc/print.css?20200622" media="print">



<!--| JS |-->
<script src="//cdn.mainichi.jp/vol1/js/jquery.min.2.1.4.js"></script>
<script src="//cdn.mainichi.jp/vol1/js/jquery.cookie.js"></script>
<script type="text/javascript" src="//cdn.mainichi.jp/vol1/js/pc/script.js?20200622"></script>
<script type="text/javascript" src="//cdn.mainichi.jp/vol1/js/mode-select.js?dt=0109"></script>
<style>
li .keyword:empty{display:none;min-height:1px;}
</style>
<link rel="stylesheet" href="//cdn.mainichi.jp/vol1/css/pc/english.css?202207">

<script async='async' src="https://flux-cdn.com/client/mainichi/mainichi2.min.js" type="text/javascript">
</script>
<script type="text/javascript">
  window.pbjs = window.pbjs || {que: []};
</script>


<script async='async' src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'></script>
<script type="text/javascript">
  window.googletag = window.googletag || {cmd: []};
</script>

<script type="text/javascript">
document.write('<scr'+'ipt type="text/javascript" src="http'+(location.protocol==='https:'?'s://s':'://')+'cdn.cxense.com/cx.js"></scr'+'ipt>');
</script>
<script>
 var cX = cX || {};cX.callQueue = cX.callQueue || [];
  cX.callQueue.push(['invoke',function(){
  googletag.cmd.push(function() {
    googletag.defineSlot('/41213723/PC/english/rec1', [[300, 600], [300, 250], 'fluid'], 'PC-english-rec1').addService(
    googletag.pubads()).setTargeting("CxSegments",cX.getUserSegmentIds({persistedQueryId:'f31589e34340c498c7c5098297d506a55eed6620'}));
    googletag.defineSlot('/41213723/PC/english/rec2', ['fluid', [300, 250]], 'PC-english-rec2').addService(
    googletag.pubads()).setTargeting("CxSegments",cX.getUserSegmentIds({persistedQueryId:'f31589e34340c498c7c5098297d506a55eed6620'}));
    googletag.pubads().setTargeting("url","https://mainichi.jp/english/articles/20220916/p2a/00m/0sc/017000c");
    googletag.pubads().setTargeting("keywords","Science,Technology,Latest Articles,The Mainichi,JAPAN");
    googletag.pubads().setTargeting("genreBig","p2a");
    googletag.pubads().setTargeting("genreMedium","");
    googletag.pubads().setTargeting("genreSmall","");
    googletag.pubads().setTargeting("subjectCode","technology");
    googletag.pubads().setTargeting("kanrenMidashi","");
    googletag.pubads().setTargeting("category","Science");
    googletag.pubads().setTargeting("articleType","free-entry");
    googletag.pubads().setTargeting("entitlement","non-login");
    googletag.pubads().setCentering(true);
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.pubads().enableLazyLoad({fetchMarginPercent: 10, renderMarginPercent: 60, mobileScaling: 2.0});
    var cookiesArray = document.cookie.split("; ");
    var cid = cid || '';
    for(var i=0; i<cookiesArray.length; i++){
        if(cookiesArray[i].split("=")[0] == "_ga"){
            cid = cookiesArray[i].split("=")[1].substr(6);
            break;
        }
    }
    var ppid = (cid+cid).replace(/(\.||-||_)/g,"").substring(0,149);
    googletag.pubads().setPublisherProvidedId(ppid);
    googletag.enableServices();
    if (!!(window.pbFlux) && !!(window.pbFlux
      .prebidBidder) && fluxtag.isFn(
      window.pbFlux.prebidBidder)) {
      pbjs.que.push(function () {
        window.pbFlux
          .prebidBidder();
      });
    } else {
      // Prebidが呼び出せない場合、すぐにGAMを呼び出す
      fluxtag.readyBids.prebid = true;
      fluxtag.launchAdServer();
    }
  });
}]);
  //Async load of cx.js
  (function(d,s,e,t){e=d.createElement(s);e.type='text/java'+s;e.async='async';
  e.src='http'+('https:'===location.protocol?'s://s':'://')+'cdn.cxense.com/cx.js';
  t=d.getElementsByTagName(s)[0];t.parentNode.insertBefore(e,t);})(document,'script');
</script>


<!-- Page hiding snippet (recommended) -->
<style>.async-hide { opacity: 0 !important} </style>
<script>
(function(a,s,y,n,c,h,i,d,e){s.className+=' '+y;
h.end=i=function(){s.className=s.className.replace(RegExp(' ?'+y),'')};
(a[n]=a[n]||[]).hide=h;setTimeout(function(){i();h.end=null},c);
})(window,document.documentElement,'async-hide','dataLayer',4000,{'GTM-5M48NC':true});
</script>


<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5M48NC"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5M48NC');</script>
<!-- End Google Tag Manager -->
</head>
<body>
<p class="hide"><a href="#main">Please view the main text area of the page by skipping the main menu.</a></p>
<noscript>
<p class="nojs">The page may not be displayed properly if the JavaScript is deactivated on your browser.</p>
</noscript>

<!--| header BGN |-->
<header id="top">
<!--| header-box BGN |-->
<nav class="header-main">

<!--| container BGN |-->
<div class="container">

<p class="logo"><a href="/english/"><img src="//cdn.mainichi.jp/vol1/images/pc/logo-theMainichi.png" width="230" alt="The Mainichi">
<span>Japan's National Daily Since 1922</span></a></p>
<ul>
<li class="search">
<div class="header-search">
<form method="get" action="/english/search" id="hsearch" name="hsearch" enctype="application/x-www-form-urlencoded">
<div id="search-input"><input type="text" class="form-input" name="q"><input type="hidden" name="la" value="en-US"><input type="hidden" name="da" value="all"><input type="hidden" name="s" value="dd"></div>
<div id="search-btn"><input type="submit" class="form-btn" value="Search"></div>
</form>
</div>
</li>
<li class="sublink"><a href="https://mainichi.jp/">Japanese</a></li>
<li class="sublink"><a href="https://mainichi.jp/english/contact/">Contact Us</a></li>
</ul>

</div>
<!--| container END |-->

</nav>
<!--| header-box END |-->

<!--| main-navi BGN |-->
<div id="mainNavi" class="main-navi">
<!--| container BGN |-->
<div class="container">
<ul>
<li><a href="//mainichi.jp/english/">Top</a></li>
<li><a href="//mainichi.jp/english/latest/">Latest</a></li>
<li><a href="//mainichi.jp/english/japan/">Japan</a></li>
<li><a href="//mainichi.jp/english/world/">World</a></li>
<li><a href="//mainichi.jp/english/business/">Business</a></li>
<li><a href="//mainichi.jp/english/sports/">Sports</a></li>
<li><a href="//mainichi.jp/english/science/">Science</a></li>
<li><a href="//mainichi.jp/english/entertainment/">Entertainment</a></li>
<li><a href="//mainichi.jp/english/opinion/">Opinion</a></li>
<li><a href="//mainichi.jp/english/lifestyle/">Lifestyle</a></li>
<li><a href="//mainichi.jp/english/obituaries/">Obituaries</a></li>
<li><a href="//mainichi.jp/english/features/">Features</a></li>
<li><a href="//mainichi.jp/english/photos/">Photos</a></li>
<li><a href="//mainichi.jp/english/videos/">Videos</a></li>
</ul>
</div>
<!--| container END |-->
</div>
<!--| main-navi END |-->


</header>
<!--| header END |-->



<!--| container BGN |-->
<div class="container">
<!--| main BGN |-->
<div id="main">
<!--| article BGN |-->
<article id="main-cont">

<!--| header BGN |-->
<header>
<!--| header-box BGN |-->
<div class="header-box">
<ul class="inline-list">

</ul>
</div>

<!--| header-box BGN |-->
<h1>Unique 2-in-1 calculator app adds up to surprise hit for retired engineer in Japan</h1>
<div class="article-infoBox">
<div class="article-info">
<p class="post"><time>September 18, 2022</time> (Mainichi Japan)</p>

</div>
<!--| sub BGN |-->
<div class="sub">
<p class="japanese"><a href="//mainichi.jp/articles/20220910/k00/00m/040/136000c">Japanese version</a></p></div>
<!--| sub END |-->
</div>
</header>
<!--| header END |-->



<!--| main-text BGN |-->
<div class="main-text">
<!-- cxenseparse_start -->

<div class="img-left">
<figure>
<div class="img">
<a data-href="https://cdn.mainichi.jp/vol1/2022/09/16/20220916p2a00m0sc014000p/9.jpg?1" data-lightbox="photos" data-title="This image shows an app that displays two calculators on one screen. The calculation result on the calculator on the left can be moved to the one on the right by tapping the arrow key, enabling users to continue computations. (Mainichi)">
<span class="wrap">
<img src="https://cdn.mainichi.jp/vol1/2022/09/16/20220916p2a00m0sc014000p/6.jpg?1" alt="" class="horizontal-photo">
<div class="img-zoom" title="拡大写真"></div>
</span>
<div class="img-mask"></div>
</a>
</div>
<figcaption>This image shows an app that displays two calculators on one screen. The calculation result on the calculator on the left can be moved to the one on the right by tapping the arrow key, enabling users to continue computations. (Mainichi)</figcaption>
</figure>
</div>
<p class="txt">
    TOKYO -- A 63-year-old man in Japan who is an avid iPhone user has dedicated some of his post-retirement years to developing a popular, unique app that displays two calculators on one screen.
</p>
<!-- cxenseparse_end -->
<div><ul class="list-typeD typeD-line"></ul></div>
<!-- cxenseparse_start -->
<p class="txt">
    The two-in-one calculator app has been released for iPhone and iPad, under the name "Twin-Calc." Hiroyuki Ueda, who lives in Nishinomiya, Hyogo Prefecture, is the mastermind behind it. Though the app struggled to gain downloads in the beginning after its release, the number surged once he made a certain tweak.
</p>
<p class="txt">
    The double calculator app allows users to move the computation results of one calculator onto the other by tapping arrow keys displayed on the middle of the screen. For example, if a user calculates "89 x 15 = 1335" on one calculator and taps the arrow key, the result "1335" will be displayed on the other calculator, allowing the user to continue a problem while the previous equations are still shown on the screen. This makes it easy to notice errors.
</p>
<p class="txt">
    It is also possible to perform different computations on each calculator. This function comes in handy when the user wants to compare prices to determine which store product is cheaper by the gram, for example.
</p>

<div class="img-left">
<figure>
<div class="img">
<a data-href="https://cdn.mainichi.jp/vol1/2022/09/16/20220916p2a00m0sc015000p/9.jpg?1" data-lightbox="photos" data-title="This image shows the app which combines two calculators onto one screen. Users can also perform separate computations on each calculator. (Mainichi)">
<span class="wrap">
<img src="https://cdn.mainichi.jp/vol1/2022/09/16/20220916p2a00m0sc015000p/6.jpg?1" alt="" class="horizontal-photo">
<div class="img-zoom" title="拡大写真"></div>
</span>
<div class="img-mask"></div>
</a>
</div>
<figcaption>This image shows the app which combines two calculators onto one screen. Users can also perform separate computations on each calculator. (Mainichi)</figcaption>
</figure>
</div>
<p class="txt">
    Ueda studied mechanical design at university, and worked mainly in engineering, including the design of transmission components, at an automobile firm for many years before retiring at age 60.
</p>
<p class="txt">
    He was originally a great iPhone fan and took up learning the Swift programming language as he had time on his hands after retirement. He was finally able to realize his dream of giving shape to inventions he thought would be convenient.
</p>
<p class="txt">
    Ueda directed his attention to calculators, as they are closely tied with people's daily lives and are a universal tool without any language barriers. He began working out the vision for the app three to four years ago, and started actually developing it in August 2021. According to Ueda, an app that combined two calculators on one screen did not exist at this point, and seizing this chance to make a one of a kind software, he aimed to develop apps for the iPhone and iPad.
</p>
<p class="txt">
    However, Ueda recalled, "I thought it'd be easy, but it was unexpectedly hard." Difficulties arose when responding to cases of inputting numbers with decimal points. For example, while there are users who input 0.5 by tapping "0," the decimal point, and then "5," there are also users who only input the decimal point and "5," while omitting the "0." He said, "There were around 100 types of these sort of conditions, and it was a lot of work to solve them."
</p>

<div class="img-left">
<figure>
<div class="img">
<a data-href="https://cdn.mainichi.jp/vol1/2022/09/16/20220916p2a00m0sc016000p/8.jpg?1" data-lightbox="photos" data-title="Hiroyuki Ueda, the developer of "Twin-Calc," is seen in this image provided by him.">
<span class="wrap">
<img src="https://cdn.mainichi.jp/vol1/2022/09/16/20220916p2a00m0sc016000p/6.jpg?1" alt="" class="horizontal-photo">
<div class="img-zoom" title="拡大写真"></div>
</span>
<div class="img-mask"></div>
</a>
</div>
<figcaption>Hiroyuki Ueda, the developer of "Twin-Calc," is seen in this image provided by him.</figcaption>
</figure>
</div>
<p class="txt">
    After trial and error, he was able to release the app nine months later in May 2022. The number of downloads grew at a sluggish pace at first because the app was designed so that just one calculator is displayed on the smartphone's vertical screen mode, while two are shown only when the screen is rotated on its side. So, many users only thought it was a regular calculator.
</p>
<p class="txt">
    Ueda then made alterations so that the app is fixed on horizontal display and that two calculators are always displayed simultaneously after the app is opened. This renewed version was released on Aug. 18. According to Ueda, as of Sept. 8, there were about 56,800 downloads for the version that costs 490 yen (about $3), including tax, and some 5,000 downloads for the free version. The paid version had around 18,000 downloads shortly before the renewal, so the amount had more than tripled following the update.
</p>
<p class="txt">
    He commented, "A surprisingly great number of people have downloaded the app. I think there is demand." The latest task he is working on is to respond to requests to display two calculators even on a vertical display screen.
</p>
<p class="txt">
    Ueda, who says there are few people in his generation who are tech-savvy, commented, "I hope I can become someone who inspires others."
</p>
<p class="txt">
    (Japanese original by Tsuyoshi Goto, Digital News Center)
</p>
<!-- cxenseparse_end -->

<!--| tools BGN |-->
<div id="tools">
<ul>
<li class="btn-fontSize"><a href="#" class="btn" title="Font Size">Font Size</a>
<ul class="tool"><li class="font-s fonts">S</li><li class="font-m fonts">M</li><li class="font-l fonts">L</li></ul></li>
<li class="btn-print"><a href="javascript:void(0);" onClick="window.print();return false;" class="btn" title="Print">Print</a></li>
<li class="btn-share active"><ul class="share tool"></ul></li>
</ul>
</div>
<!--| tools END |-->
</div>
<!--| main-text END |-->

<!--| aside BGN |-->
<aside class="nav">
<ul>
<li><a href="/english/">Go to The Mainichi Home Page</a></li>
</ul>
</aside>
<!--| aside END |-->

<!--| 関連記事 BGN |-->
<div class="links">
<h2>Related Articles</h2>
<ul class="list-typeA">

<li><a href="//mainichi.jp/english/articles/20220908/p2a/00m/0na/015000c" class="icon_video"><span class="midashi">Abacus app developed in Japan to learn mental math calculation skills a global hit</span></a></li>
</ul>
</div>
<!--| 関連記事 END |-->



</article>
<!--| article END |-->

<!--| Recommend BGN |-->
<div class="recommend col-set">
<h2>Also in The Mainichi</h2>
<div id="cx_recsBottomOfArticleccePC"></div>
</div>
<!--| Recommend END |-->
<!--| Recomend BGN |-->
<aside class="ad">
<!--| Outbrain content widget: PC English Article Bottom BGN |-->
<div class="OUTBRAIN" data-src="https://mainichi.jp/english/articles/20220916/p2a/00m/0sc/017000c" data-widget-id="AR_8" data-ob-template="TheMainichi"></div>
<div class="OUTBRAIN" data-src="https://mainichi.jp/english/articles/20220916/p2a/00m/0sc/017000c" data-widget-id="AR_9" data-ob-template="TheMainichi"></div>
<div class="OUTBRAIN" data-src="https://mainichi.jp/english/articles/20220916/p2a/00m/0sc/017000c" data-widget-id="AR_10" data-ob-template="TheMainichi"></div>
<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
<!--| Outbrain content widget END |-->
</aside>
<!--| Recomend END |-->

</div>
<!--| main END |-->

<!--| sub BGN |-->
<div id="sub">

<!-- PC-english-rec1 -->
<div id='PC-english-rec1' style='min-width: 300px; min-height: 250px;'>
<script>
cX.callQueue.push(['invoke',function(){
googletag.cmd.push(function() { googletag.display('PC-english-rec1'); });
}]);
</script>
</div>

<!--| sns BGN |-->
<dl class="accounts">
<dt style="float:none">The Mainichi on social media</dt>
<dd>
<ul class="inline-list">
<li class="fb btn-sns"><a href="http://www.facebook.com/themainichi" target="_blank" title="Facebook"><span></span></a></li>
<li class="tw btn-sns"><a href="https://twitter.com/themainichi" target="_blank" title="twitter"><span></span></a></li>
<li class="ig btn-sns"><a href="https://www.instagram.com/themainichi/" target="_blank" title="instagram"><span></span></a></li>
<li class="rss btn-sns"><a href="/english/rss/" title="RSS">RSS<span></span></a></li>
</ul>
</dd>
</dl>
<!--| sns END |-->

<!--| section BGN |-->
<div class="section">
<h2>Latest Articles</h2>
<ul class="list-typeD">
<li>
<a href="//mainichi.jp/english/articles/20220826/p2g/00m/0su/049000c">
<span class="midashi ">Haiku in English: Sept. 21, 2022</span>
</a>
</li>
<li>
<a href="//mainichi.jp/english/articles/20220920/p2g/00m/0sp/059000c">
<div class="thumb img"><img src="https://cdn.mainichi.jp/vol1/2022/09/20/20220920p2g00m0sp058000p/4.jpg?1" alt="Shuta Ishikawa of the SoftBank Hawks pitches against the Nippon Ham Fighters in a Pacific League baseball game at Sapporo Dome in Sapporo, northern Japan, on Sept. 20, 2022. (Kyodo)" class="horizontal-photo"><div class="img-mask"></div></div>
<span class="midashi ">Baseball: Shuta Ishikawa, Yuki Yanagita lead Hawks over Fighters</span>
</a>
</li>
<li>
<a href="//mainichi.jp/english/articles/20220920/p2g/00m/0sp/057000c">
<div class="thumb img"><img src="https://cdn.mainichi.jp/vol1/2022/09/20/20220920p2g00m0sp056000p/5.jpg?1" alt="Naomi Osaka of Japan returns a shot to Daria Saville of Australia during their first-round match of the Toray Pan Pacific Open in Tokyo on Sept. 20, 2022. (Kyodo)" class="vertical-photo"><div class="img-mask"></div></div>
<span class="midashi ">Tennis: Naomi Osaka advances as injured Daria Saville retires in Tokyo</span>
</a>
</li>
</ul>
<p class="txt-right small">
<a href="//mainichi.jp/english/latest/1">More Articles</a>
</p>
</div>
<!--| section END |-->

<!--| section BGN |-->
<div class="section">
<h2>Trending</h2>
<!--| Cxense content widget: PC 英語版 記事ページ ライトパネル BGN |-->
<div id="cx_recsrightCol" style="height:1px;"></div>
<div id="cx_recsTargetRightCol" style="display: none;"></div>
<script type="text/javascript">
    var cX = cX || {}; cX.callQueue = cX.callQueue || [];
    cX.callQueue.push(['invoke', function() {
      var point = document.getElementById('cx_recsrightCol') ? document.getElementById('cx_recsrightCol').id : "cx_recsrightCol";
      cX.trackElement({elementId: point,
        trigger: {
          on: function(state) { return state.visibility.maxPercent > 0; },
          callback: function(state) {
            cX.setSiteId('9222356687186286883');
            cX.setEventAttributes({origin:'mai-web', persistedQueryId:'fead2bc65fbe64e10dbc2f536fe1f09ba4412432'});
            cX.sendEvent('inview', {widgetId:'c272bb0f76ee4cc1b87c073ad8f6b8b41550214b',widgetName:"PC右カラム（英語）"});
          }
        }
      });
    }]);
    cX.callQueue.push(['insertWidget', {
        widgetId: 'c272bb0f76ee4cc1b87c073ad8f6b8b41550214b',
        insertBeforeElementId: 'cx_recsTargetRightCol',
        width: '100%', height: 416, renderTemplateUrl: 'auto',
    }]);
    // Async load of cx.js
    (function(d,s,e,t){e=d.createElement(s);e.type='text/java'+s;e.async='async';
    e.src='http'+('https:'===location.protocol?'s://s':'://')+'cdn.cxense.com/cx.js';
    t=d.getElementsByTagName(s)[0];t.parentNode.insertBefore(e,t);})(document,'script');
</script>
<!--| Cxense content widget END |-->
</div>
<!--| section END |-->
<!-- PC-english-rec2 -->
<div id='PC-english-rec2' >
<script>
cX.callQueue.push(['invoke',function(){
googletag.cmd.push(function() { googletag.display('PC-english-rec2'); });
}]);
</script>
</div>

</div>
<!--| sub END |-->

</div>
<!--| container END |-->

<!--| contents-end BGN |-->
<div class="contents-end">
<div class="container">
<ul>
<li><a href="#top">Go to Page Top</a></li>
</ul>
</div>
</div>
<!--| contents-end END |-->



<footer>

<!--| sitemap BGN |-->
<div class="sitemap">

<div class="container">

<ul class="sitemap-list inline-list">

<li>
<dl>
<dt><a href="/english/japan/">Japan</a></dt>
<dd>
<ul>
<li><a href="/english/japan/crime-accidents/">Crime &amp; Accidents</a></li>
<li><a href="/english/japan/politics/">Politics</a></li>
<li><a href="/english/japan/social-issues/">Social Issues</a></li>
<li><a href="/english/japan/weather-disasters/">Weather &amp; Disasters</a></li>
<li><a href="/english/japan/history-festivals/">History &amp; Festivals</a></li>
<li><a href="/english/japan/education/">Education</a></li>
<li><a href="/english/japan/imperial-family/">Imperial Family</a></li>
<li><a href="/english/japan/polls/">Polls</a></li>
</ul>
</dd>
</dl>
</li>

<li>
<dl>
<dt><a href="/english/world/">World</a></dt>
<dd>
<ul>
<li><a href="/english/world/asia-oceania/">Asia &amp; Oceania</a></li>
<li><a href="/english/world/usa-canada/">USA &amp; Canada</a></li>
<li><a href="/english/world/europe/">Europe</a></li>
<li><a href="/english/world/middle-east/">Middle East</a></li>
<li><a href="/english/world/latin-america/">Latin America</a></li>
<li><a href="/english/world/africa/">Africa</a></li>
</ul>
</dd>
<dt><a href="/english/business/">Business</a></dt>
<dd>
<ul>
<li><a href="/english/business/corporate/">Corporate</a></li>
<li><a href="/english/business/economy/">Economy</a></li>
<li><a href="/english/business/financial/">Financial</a></li>
<li><a href="/english/business/agriculture-fisheries/">Agriculture &amp; Fisheries</a></li>
</ul>
</dd>
</dl>
</li>

<li>
<dl>
<dt><a href="/english/sports/">Sports</a></dt>
<dd>
<ul>
<li><a href="/english/sports/baseball/">Baseball</a></li>
<li><a href="/english/sports/soccer/">Soccer</a></li>
<li><a href="/english/sports/sumo/">Sumo</a></li>
<li><a href="/english/sports/tennis/">Tennis</a></li>
<li><a href="/english/sports/golf/">Golf</a></li>
<li><a href="/english/sports/rugby/">Rugby</a></li>
<li><a href="/english/sports/athletics/">Athletics</a></li>
<li><a href="/english/sports/winter-sports/">Winter Sports</a></li>
<li><a href="/english/sports/olympics-paralympics/">Olympics &amp; Paralympics</a></li>
</ul>
</dd>
</dl>
</li>

<li>
<dl>
<dt><a href="/english/science/">Science</a></dt>
<dd>
<ul>
<li><a href="/english/science/technology/">Technology</a></li>
<li><a href="/english/science/medical/">Medical</a></li>
<li><a href="/english/science/environment/">Environment</a></li>
<li><a href="/english/science/space/">Space</a></li>
</ul>
</dd>
<dt><a href="/english/entertainment/">Entertainment</a></dt>
<dd>
<ul>
<li><a href="/english/entertainment/anime-manga/">Anime &amp; Manga</a></li>
<li><a href="/english/entertainment/showbiz/">Showbiz</a></li>
<li><a href="/english/entertainment/culture/">Culture</a></li>
<li><a href="/english/entertainment/amusement/">Amusement</a></li>
<li><a href="/english/entertainment/film/">Film</a></li>
<li><a href="/english/entertainment/music/">Music</a></li>
<li><a href="/english/entertainment/books/">Books</a></li>
</ul>
</dd>
</dl>
</li>

<li>
<dl>
<dt><a href="/english/opinion/">Opinion</a></dt>
<dd>
<ul>
<li><a href="/english/opinion/editorial/">Editorial</a></li>
<li><a href="/english/opinion/news-navigator/">News Navigator</a></li>
<li><a href="/english/opinion/perspectives/">Perspectives</a></li>
</ul>
</dd>
<dt><a href="/english/lifestyle/">Lifestyle</a></dt>
<dd>
<ul>
<li><a href="/english/lifestyle/animals/">Animals</a></li>
<li><a href="/english/lifestyle/travel/">Travel</a></li>
<li><a href="/english/lifestyle/health/">Health</a></li>
<li><a href="/english/lifestyle/food/">Food</a></li>
<li><a href="/english/lifestyle/fashion/">Fashion</a></li>
</ul>
</dd>
</dl>
</li>

<li>
<dl>
<dt><a href="/english/features/">Features</a></dt>
<dd>
<ul>
<li><a href="/english/hibakusha/">A-bomb Survivors</a></li>
</ul>
</dd>
<dt><a href="/english/obituaries/">Obituaries</a></dt>
<dd>
<ul>
<li>&nbsp;</li>
</ul>
</dd>
<dt><a href="/english/photos/">Photos</a></dt>
<dd>
<ul>
<li><a href="/english/photos/japan-photo-journal/">Photo Journal</a></li>
<li><a href="/english/photos/photo-specials/">Photo Specials</a></li>
</ul>
</dd>
<dt><a href="/english/videos/">Videos</a></dt>
</dl>
</li>

</ul>

<dl class="sitemap-list2">
<dt>The Mainichi on social media</dt>
<dd>
<ul class="inline-list">
<li class="fb btn-sns"><a href="http://www.facebook.com/themainichi" target="_blank" title="Facebook"></a></li>
<li class="tw btn-sns"><a href="https://twitter.com/themainichi" target="_blank" title="twitter"></a></li>
<li class="ig btn-sns"><a href="https://www.instagram.com/themainichi/" target="_blank" title="instagram"></a></li>
</ul>
</dd>
</dl>

</div>

</div>
<!--||-->



<!--| infomation |-->
<div class="infomation">
<div class="container">

<p class="logo"><img src="//cdn.mainichi.jp/vol1/images/pc/logo-mainichi_w_e.png"></p>

<ul class="inline-list">
<li><a href="/english/info/copyright_en.html">Copyright</a></li>
<li><a href="https://www.mainichi.co.jp/corporate/privacypolicy.html">Privacy Policy</a></li>
<li><a href="https://macs.mainichi.co.jp/digital/" target="_blank">Advertise with Us</a></li>
<li><a href="https://mainichi.jp/english/contact/">Contact Us</a></li>
</ul>

<p>Copyright THE MAINICHI NEWSPAPERS. All rights reserved.</p>

</div>
</div>
<!--||-->

</footer>
<!--| script BGN |-->
<script type="text/javascript" src="https://cdn.mainichi.jp/vol1/js/pc/lightbox.js"></script>
<script type="text/javascript" src="https://cdn.mainichi.jp/vol1/js/pc/script-lightbox.js"></script>
<!--| script BGN |-->
<!-- cXense CCE #3472 -->
<div id="cxSubscMsg"></div>
<div id="cxGdprMsg"></div>
<div id="cxPageBottomBnr"></div>
<div id="cxPageModalBnr"></div>

<!--リスティング広告計測用 #3705 -->
<script id="tagjs" type="text/javascript">
  (function () {
    var tagjs = document.createElement("script");
    var s = document.getElementsByTagName("script")[0];
    tagjs.async = true;
    tagjs.src = "//s.yjtag.jp/tag.js#site=LAFKJA6";
    s.parentNode.insertBefore(tagjs, s);
  }());
</script>
<noscript>
  <iframe src="//b.yjtag.jp/iframe?c=LAFKJA6" width="1" height="1" title="yjtag"></iframe>
</noscript>
</body>
</html>